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Introduction

This model is based on the Step Thrust Bearing model in the Rotordynamics Module 
Application Library. In the present example, shape optimization is applied to identify the 
optimal shape of grooves and pads as well as their optimal number.

Model Definition

The geometry and mesh are fixed, as is the norm for shape optimization. The out-of-plane 
geometry is defined in terms of a spatially varying bearing clearance; see Figure 1.

Figure 1: Initial step thrust bearing geometry.

The shape is optimized by deforming the geometry in the azimuthal direction. This 
deformation varies depending on the radial coordinate. It is implemented using the Control 

Function feature and the Deformed Geometry interface. Different functions are used for the 
leading and trailing edges of the pads, but all pads have the same shape. The Coefficient 

Form Boundary PDE and Coefficient Form Edge PDE interfaces are used to compute the 
displacement field for the interior mesh element of the pads and grooves.

The bearing load capacity is used as objective function. The amount of design freedom is 
determined by the order of the control functions and the maximum azimuthal 
deformation. Too aggressive settings can, however, be expected to introduce problems 
with inverted elements.

Groove

Pad
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Results and Discussion

Figure 2 shows the optimized bearing for the case of five grooves.

Figure 2: The edges of the optimized bearing is shown for the case of five grooves.

The shape optimization deforms the mesh, and this can impact the simulation accuracy, so 
it is good practice to remesh the geometry in the deformed configuration and recompute 
the result. Comparing the raw optimization results with such a verification simulation can 
reveal if the optimization relies on unphysical effects rooted in numerical errors, but this 
does not seem to be the case as illustrated in Figure 3.

Finally, one can identify the optimal number of pads by wrapping a optimization study 
with a Parametric Sweep, the result of which is shown in Figure 4.
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Figure 3: A comparison between the pressure distribution on the optimization mesh and on a 
mesh generated in the deformed configuration.
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Figure 4: The optimized bearing load capacity is plotted versus the number of pads.

Application Library path: Optimization_Module/Shape_Optimization/
step_thrust_bearing_shape_optimization

Modeling Instructions

This example starts from an existing model from the Rotordynamics Module Application 
Library.

A P P L I C A T I O N  L I B R A R I E S

1 From the File menu, choose Application Libraries.

2 In the Application Libraries window, select Rotordynamics Module>Tutorials>

step_thrust_bearing in the tree.

3 Click Open.
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G L O B A L  D E F I N I T I O N S

Parameters 1
Introduce a parameter for the maximum azimuthal deformation and increase the groove 
angle to allow larger mesh deformation.

1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

Define some selections for later use.

C O M P O N E N T  1  ( C O M P 1 )

In the Model Builder window, expand the Component 1 (comp1) node.

G E O M E T R Y  1

In the Model Builder window, expand the Component 1 (comp1)>Geometry 1 node.

Work Plane 1 (wp1)
In the Model Builder window, expand the Component 1 (comp1)>Geometry 1>

Work Plane 1 (wp1) node.

Circular Boundaries
1 In the Model Builder window, expand the Component 1 (comp1)>Geometry 1>

Work Plane 1 (wp1)>Plane Geometry node.

2 Right-click Geometry 1 and choose Selections>Adjacent Selection.

3 In the Settings window for Adjacent Selection, locate the Input Entities section.

4 From the Geometric entity level list, choose Boundary.

5 Click Add.

6 In the Add dialog box, in the Input selections list, choose Grooves and Pads.

7 Click OK.

8 In the Settings window for Adjacent Selection, locate the Output Entities section.

9 From the Geometric entity level list, choose Adjacent edges.

Name Expression Value Description

N 5 5 Number of pads

gAng 25[deg] 0.43633 rad Groove angle (deg)

maxAngle 8[deg] 0.13963 rad Limit on pad profile angle
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10 In the Label text field, type Circular Boundaries.

Trailing Edge Points
1 In the Geometry toolbar, click Selections and choose Adjacent Selection.

2 In the Settings window for Adjacent Selection, locate the Input Entities section.

3 From the Geometric entity level list, choose Edge.

4 Click Add.

5 In the Add dialog box, select Trailing Edges of the Pads in the Input selections list.

6 Click OK.

7 In the Settings window for Adjacent Selection, locate the Output Entities section.

8 From the Geometric entity level list, choose Adjacent points.

9 In the Label text field, type Trailing Edge Points.

Leading Edge Points
1 Right-click Trailing Edge Points and choose Duplicate.

2 In the Settings window for Adjacent Selection, locate the Input Entities section.

3 Click Build Preceding State.

4 In the Input selections list, select Trailing Edges of the Pads.

5 Click Delete.

6 Click Add.

7 In the Add dialog box, select Leading Edges of the Pads in the Input selections list.

8 Click OK.

9 In the Settings window for Adjacent Selection, type Leading Edge Points in the Label 
text field.

10 Click Build Selected.

Circular & pad edges
1 In the Geometry toolbar, click Selections and choose Union Selection.

2 In the Settings window for Union Selection, locate the Geometric Entity Level section.

3 From the Level list, choose Edge.

4 Locate the Input Entities section. Click Add.

5 In the Add dialog box, in the Selections to add list, choose Leading Edges of the Pads, 
Trailing Edges of the Pads, and Circular Boundaries.

6 Click OK.
7 |  S H A P E  O P T I M I Z A T I O N  O F  A  S T E P  T H R U S T  B E A R I N G



7 In the Settings window for Union Selection, type Circular & pad edges in the Label 
text field.

8 In the Model Builder window, collapse the Geometry 1 node.

Add a couple of control functions to control the leading and trailing edge shapes of the 
pads.

C O M P O N E N T  1  ( C O M P 1 )

Control Function 1 (cfunc1)
1 In the Definitions toolbar, click Optimization and choose Control Variables>

Control Function.

2 In the Settings window for Control Function, locate the Input section.

3 In the n text field, type 3.

4 Locate the Output section. In the fmin text field, type -maxAngle.

5 In the fmax text field, type maxAngle.

6 In the c0 text field, type maxAngle/10.

It is possible to initialize the Control Function to zero, but then the machinery for 
automatic scaling of the coefficient PDEs fails, so one has to resort to manually scaling.

7 Locate the Units section. In the Argument text field, type 1.

8 In the Function text field, type rad.

Control Function 2 (cfunc2)
Right-click Control Function 1 (cfunc1) and choose Duplicate.

D E F I N I T I O N S  ( C O M P 1 )

Define variables to specify the motions of the pad boundaries.

Variables: Trailing edge motion
1 In the Model Builder window, expand the Component 1 (comp1)>Definitions node.

2 Right-click Component 1 (comp1)>Definitions and choose Variables.

3 In the Settings window for Variables, type Variables: Trailing edge motion in the 
Label text field.

4 Locate the Geometric Entity Selection section. From the Geometric entity level list, 
choose Edge.

5 From the Selection list, choose Trailing Edges of the Pads.
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6 Locate the Variables section. In the table, enter the following settings:

Variables: Leading edge motion
1 Right-click Variables: Trailing edge motion and choose Duplicate.

2 In the Settings window for Variables, locate the Geometric Entity Selection section.

3 From the Selection list, choose Leading Edges of the Pads.

4 In the Label text field, type Variables: Leading edge motion.

5 Locate the Variables section. In the table, enter the following settings:

Variables: Circular boundary motion
1 Right-click Variables: Leading edge motion and choose Duplicate.

2 In the Settings window for Variables, locate the Geometric Entity Selection section.

3 From the Selection list, choose Circular Boundaries.

4 Locate the Variables section. In the table, enter the following settings:

Name Expression Unit Description

Re sqrt(Xg^2+
Yg^2)

m Radial coordinate

phie atan2(Yg, 
Xg)

rad Circumferential coordinate

se (Re-Ri)/(Ro-
Ri)

Scaled radial coordinate

movexef cos(phie+
cfunc1(se))*
Re-Xg

m Displacement, x direction

moveyef sin(phie+
cfunc1(se))*
Re-Yg

m Displacement, y direction

Name Expression Unit Description

movexef cos(phie+cfunc2(se))*
Re-Xg

m Displacement, x 
direction

moveyef sin(phie+cfunc2(se))*
Re-Yg

m Displacement, y 
direction

Name Expression Unit Description

se (Re-Ri)/(Ro-Ri) Scaled radial coordinate
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5 Click Delete.

6 In the Label text field, type Variables: Circular boundary motion.

Add boundary and edge PDEs to solve for the mesh deformation in the pad.

A D D  P H Y S I C S

1 In the Home toolbar, click Add Physics to open the Add Physics window.

2 Go to the Add Physics window.

3 In the tree, select Mathematics>PDE Interfaces>Lower Dimensions>

Coefficient Form Boundary PDE (cb) and Mathematics>PDE Interfaces>Lower Dimensions>

Coefficient Form Edge PDE (ce).

4 Click Add to Component 1 in the window toolbar.

5 In the tree, select Mathematics>Deformed Mesh>Deformed Geometry>

Prescribed Deformation.

6 Click Add to Component 1 in the window toolbar.

7 In the Home toolbar, click Add Physics to close the Add Physics window.

C O E F F I C I E N T  F O R M  B O U N D A R Y  P D E  ( C B )

1 In the Model Builder window, under Component 1 (comp1) click 
Coefficient Form Boundary PDE (cb).

2 In the Settings window for Coefficient Form Boundary PDE, click to expand the 
Dependent Variables section.

3 In the Field name text field, type movef.

4 In the Number of dependent variables text field, type 2.

5 In the Dependent variables table, enter the following settings:

6 Locate the Units section. Click Select Dependent Variable Quantity.

7 In the Physical Quantity dialog box, type length in the text field.

movexef cos(phie+phieMove)*Re-
Xg

Displacement, x 
direction

moveyef sin(phie+phieMove)*Re-
Yg

Displacement, y 
direction

movexf

moveyf

Name Expression Unit Description
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8 Click Filter.

9 In the tree, select General>Length (m).

10 Click OK.

11 In the Settings window for Coefficient Form Boundary PDE, locate the Units section.

12 Click Select Source Term Quantity.

13 In the Physical Quantity dialog box, type dimensionless in the text field.

14 Click Filter.

15 In the tree, select General>Dimensionless (1).

16 Click OK.

Coefficient Form PDE 1
1 In the Model Builder window, under Component 1 (comp1)>

Coefficient Form Boundary PDE (cb) click Coefficient Form PDE 1.

2 In the Settings window for Coefficient Form PDE, locate the Source Term section.

3 In the f text-field array, type 0 on the first row.

Dirichlet Boundary Condition 1
1 In the Physics toolbar, click Edges and choose Dirichlet Boundary Condition.

2 In the Settings window for Dirichlet Boundary Condition, locate the Edge Selection 
section.

3 From the Selection list, choose Circular & pad edges.

4 Locate the Dirichlet Boundary Condition section. In the r1 text field, type movexef.

5 In the r2 text field, type moveyef.

C O E F F I C I E N T  F O R M  E D G E  P D E  ( C E )

1 In the Model Builder window, under Component 1 (comp1) click 
Coefficient Form Edge PDE (ce).

2 In the Settings window for Coefficient Form Edge PDE, locate the Edge Selection section.

3 From the Selection list, choose Circular Boundaries.

4 Click to expand the Dependent Variables section. In the Field name text field, type 
phieMove.

5 Locate the Units section. Click Select Dependent Variable Quantity.

6 In the Physical Quantity dialog box, type plane angle in the text field.

7 Click Filter.
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8 In the tree, select General>Plane angle (rad).

9 Click OK.

10 In the Settings window for Coefficient Form Edge PDE, locate the Units section.

11 Click Select Source Term Quantity.

12 In the Physical Quantity dialog box, click OK.

13 In the Settings window for Coefficient Form Edge PDE, locate the Dependent Variables 
section.

14 In the Dependent variables table, enter the following settings:

Coefficient Form PDE 1
1 In the Model Builder window, under Component 1 (comp1)>

Coefficient Form Edge PDE (ce) click Coefficient Form PDE 1.

2 In the Settings window for Coefficient Form PDE, locate the Source Term section.

3 In the f text field, type 0.

Dirichlet Boundary Condition 1
1 In the Physics toolbar, click Points and choose Dirichlet Boundary Condition.

2 In the Settings window for Dirichlet Boundary Condition, locate the Point Selection 
section.

3 From the Selection list, choose Trailing Edge Points.

4 Locate the Dirichlet Boundary Condition section. In the r text field, type cfunc1(se).

Dirichlet Boundary Condition 2
1 Right-click Dirichlet Boundary Condition 1 and choose Duplicate.

2 In the Settings window for Dirichlet Boundary Condition, locate the Point Selection 
section.

3 From the Selection list, choose Leading Edge Points.

4 Locate the Dirichlet Boundary Condition section. In the r text field, type cfunc2(se).

Prescribe the mesh deformation in the Prescribed Displacement node in Deformed Geometry.

D E F O R M E D  G E O M E T R Y

Prescribed Deformation 1
1 In the Model Builder window, expand the Component 1 (comp1)>Deformed Geometry 

node, then click Prescribed Deformation 1.

phieMove
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2 In the Settings window for Prescribed Deformation, locate the Geometric Entity Selection 
section.

3 From the Geometric entity level list, choose Boundary.

4 From the Selection list, choose All boundaries.

5 Locate the Prescribed Deformation section. Specify the dx vector as

H Y D R O D Y N A M I C  B E A R I N G  ( H D B )

Add an optimization study to maximize the net lift force in the bearing.

R O O T

From the Home menu, choose Add Study.

A D D  S T U D Y

1 Go to the Add Study window.

2 Find the Studies subsection. In the Select Study tree, select General Studies>Stationary.

3 Click Add Study in the window toolbar.

4 From the Home menu, choose Add Study.

S T U D Y :  I N I T I A L  D E S I G N

1 In the Model Builder window, expand the Component 1 (comp1)>

Hydrodynamic Bearing (hdb) node, then click Study 1.

2 In the Settings window for Study, type Study: Initial Design in the Label text field.

S T U D Y  2

Shape Optimization
1 In the Study toolbar, click Optimization and choose Shape Optimization.

2 In the Settings window for Shape Optimization, locate the Optimization Solver section.

3 In the Maximum number of iterations text field, type 15.

4 In the Model Builder window, click Shape Optimization.

5 Click Replace Expression in the upper-right corner of the Objective Function section. 
From the menu, choose Component 1 (comp1)>Hydrodynamic Bearing>Fluid loads>

movexf X

moveyf Y

0 Z
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Fluid load on collar (spatial and material frames) - N>comp1.hdb.htb1.Fcz -

Fluid load on collar, z component.

6 Locate the Objective Function section. From the Type list, choose Maximization.

Scale the objective for better behavior of the optimization solver.

7 From the Objective scaling list, choose Initial solution based.

8 Locate the Output While Solving section. From the Probes list, choose None.

9 Select the Plot check box.

10 In the Model Builder window, click Study 2.

11 In the Settings window for Study, type Study: Shape Optimization in the Label text 
field.

Initialize the study to regenerate default plot for use while optimizing.

12 In the Study toolbar, click Get Initial Value.

Solution 2 (sol2)
1 In the Model Builder window, expand the Study: Shape Optimization>

Solver Configurations node.

2 In the Model Builder window, expand the Solution 2 (sol2) node, then click 
Optimization Solver 1.

3 In the Settings window for Optimization Solver, click to expand the Advanced section.

4 Locate the Optimization Solver section. Clear the Globally Convergent MMA check box.

5 Locate the Advanced section. From the Compensate for nojac terms list, choose Off.

Shape Optimization
1 In the Model Builder window, under Study: Shape Optimization click Shape Optimization.

2 In the Settings window for Shape Optimization, locate the Output While Solving section.

3 Select the Plot check box.

4 From the Plot group list, choose Pressure (Height).

5 In the Study toolbar, click Compute.

R E S U L T S

Fluid Pressure, Shape Optimization (hdb)
In the Settings window for 3D Plot Group, type Fluid Pressure, Shape Optimization 
(hdb) in the Label text field.

Delete the default plots for the pad motion.
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3D Plot Group 11, 3D Plot Group 12
1 In the Model Builder window, under Results, Ctrl-click to select 3D Plot Group 11 and 

3D Plot Group 12.

2 Right-click and choose Delete.

Duplicate the Pressure (Height), Mass Fraction, and Pad Profile plots from the previous study 
and change the settings to plot the shape optimized results.

Mass Fraction, Pad Profile, Pressure (Height)
1 In the Model Builder window, under Results, Ctrl-click to select Pressure (Height), 

Mass Fraction, and Pad Profile.

2 Right-click and choose Duplicate.

Surface (Shape Optimization)
1 In the Model Builder window, expand the Results>Datasets node.

2 Right-click Results>Datasets>Surface 1 and choose Duplicate.

3 In the Settings window for Surface, locate the Data section.

4 From the Dataset list, choose Study: Shape Optimization/Solution 2 (sol2).

5 In the Label text field, type Surface (Shape Optimization).

Pressure, Shape Optimization (Height)
1 In the Model Builder window, under Results click Pressure (Height) 1.

2 In the Settings window for 2D Plot Group, locate the Data section.

3 From the Dataset list, choose Surface (Shape Optimization).

4 In the Label text field, type Pressure, Shape Optimization (Height).

5 In the Pressure, Shape Optimization (Height) toolbar, click Plot.

Mass Fraction, Shape Optimization
1 In the Model Builder window, click Mass Fraction 1.

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Dataset list, choose Study: Shape Optimization/Solution 2 (sol2).

4 In the Label text field, type Mass Fraction, Shape Optimization.

5 In the Mass Fraction, Shape Optimization toolbar, click Plot.

Pad Profile, Shape Optimization
1 In the Model Builder window, click Pad Profile 1.

2 In the Settings window for 2D Plot Group, locate the Data section.
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3 From the Dataset list, choose Surface (Shape Optimization).

4 In the Label text field, type Pad Profile, Shape Optimization.

5 In the Pad Profile, Shape Optimization toolbar, click Plot.

Similarly, duplicate the radial and circumferential distribution of the pressure plots and 
change the settings for the shape optimization study to generate the plots. Note that this 
will also require duplicating the corresponding datasets.

Circumferential Distribution of Pressure (Film Thickness), Radial Distribution of Pressure 
(Film Thickness)
1 In the Model Builder window, under Results, Ctrl-click to select 

Radial Distribution of Pressure (Film Thickness) and 
Circumferential Distribution of Pressure (Film Thickness).

2 Right-click and choose Duplicate.

Cut Line 3D: Radial Line, Parameterized Curve 3D: Circumferential Line
1 In the Model Builder window, under Results>Datasets, Ctrl-click to select 

Cut Line 3D: Radial Line and Parameterized Curve 3D: Circumferential Line.

2 Right-click and choose Duplicate.

Cut Line 3D: Radial line (Optimization)
1 In the Model Builder window, under Results>Datasets, Ctrl-click to select 

Cut Line 3D: Radial Line 1 and Parameterized Curve 3D: Circumferential Line 1.

2 In the Settings window for Cut Line 3D, type Cut Line 3D: Radial line 
(Optimization) in the Label text field.

3 Locate the Data section. From the Dataset list, choose Study: Shape Optimization/

Solution 2 (sol2).

Parameterized Curve 3D: Circumferential line (Optimization)
1 In the Model Builder window, under Results>Datasets click 

Parameterized Curve 3D: Circumferential Line 1.

2 In the Settings window for Parameterized Curve 3D, type Parameterized Curve 3D: 
Circumferential line (Optimization) in the Label text field.

3 Locate the Data section. From the Dataset list, choose Study: Shape Optimization/

Solution 2 (sol2).

Radial Distribution of Pressure (Shape Optimization) 
1 In the Model Builder window, under Results click 

Radial Distribution of Pressure (Film Thickness) 1.
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2 In the Settings window for 1D Plot Group, locate the Data section.

3 From the Dataset list, choose Cut Line 3D: Radial line (Optimization).

4 In the Label text field, type Radial Distribution of Pressure (Shape 
Optimization) .

5 In the Radial Distribution of Pressure (Shape Optimization)  toolbar, click Plot.

6 Click the Show Legends button in the Graphics toolbar.

Circumferential Distribution of Pressure (Shape Optimization)
1 In the Model Builder window, click 

Circumferential Distribution of Pressure (Film Thickness) 1.

2 In the Settings window for 1D Plot Group, locate the Data section.

3 From the Dataset list, choose 
Parameterized Curve 3D: Circumferential line (Optimization).

4 In the Label text field, type Circumferential Distribution of Pressure (Shape 
Optimization).

5 In the Circumferential Distribution of Pressure (Shape Optimization) toolbar, click 
Plot.

6 Click the Show Legends button in the Graphics toolbar.

Use the following instructions to plot the deformed mesh shape after the optimization.

Mesh
1 In the Home toolbar, click Add Plot Group and choose 3D Plot Group.

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Dataset list, choose Study: Shape Optimization/Solution 2 (sol2).

4 In the Label text field, type Mesh.

Mesh 1
1 Right-click Mesh and choose Mesh.

2 In the Mesh toolbar, click Plot.

You can highlight the optimized pad shape and change from the original shape by 
following the instructions below.

Shape Optimization
1 In the Home toolbar, click Add Plot Group and choose 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Shape Optimization in the Label text 
field.
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3 Locate the Data section. From the Dataset list, choose Study: Shape Optimization/

Solution 2 (sol2).

Line 1
1 Right-click Shape Optimization and choose Line.

2 In the Settings window for Line, locate the Expression section.

3 In the Expression text field, type 1.

4 Locate the Coloring and Style section. From the Coloring list, choose Uniform.

5 From the Color list, choose Gray.

Deformation 1
1 Right-click Line 1 and choose Deformation.

2 In the Settings window for Deformation, locate the Expression section.

3 In the X component text field, type -material.dX.

4 In the Y component text field, type -material.dY.

5 In the Z component text field, type 0.

6 Locate the Scale section.

7 Select the Scale factor check box. In the associated text field, type 1.

8 In the Shape Optimization toolbar, click Plot.

Arrow Line 1
1 In the Model Builder window, right-click Shape Optimization and choose Arrow Line.

2 In the Settings window for Arrow Line, locate the Expression section.

3 In the X component text field, type material.dX.

4 In the Y component text field, type material.dY.

5 In the Z component text field, type material.dZ.

6 Locate the Arrow Positioning section. From the Placement list, choose Mesh nodes.

7 Locate the Coloring and Style section. From the Arrow base list, choose Head.

8 Select the Scale factor check box.

Color Expression 1
1 Right-click Arrow Line 1 and choose Color Expression.

2 In the Settings window for Color Expression, locate the Expression section.

3 In the Expression text field, type if(isdefined(se),abs(atan2(Y,X)-atan2(Yg,
Xg))/maxAngle,nan).
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4 Click to expand the Range section. Select the Manual color range check box.

5 In the Minimum text field, type -1.

6 In the Maximum text field, type 1.

Surface 1
1 In the Model Builder window, right-click Shape Optimization and choose Surface.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type hf.

4 Locate the Coloring and Style section. From the Color table transformation list, choose 
Reverse.

5 In the Shape Optimization toolbar, click Plot.

Shape Optimization
1 In the Model Builder window, click Shape Optimization.

2 In the Settings window for 3D Plot Group, locate the Color Legend section.

3 From the Position list, choose Right double.

Circumferential Distribution of Pressure (Angular Speed), Circumferential Distribution of 
Pressure (Film Thickness), Fluid Pressure (hdb), Lift Force, Mass Fraction, Pad Profile, 
Pressure (Height), Radial Distribution of Pressure (Angular Speed), Radial Distribution 
of Pressure (Film Thickness)
1 In the Model Builder window, under Results, Ctrl-click to select Fluid Pressure (hdb), 

Pressure (Height), Mass Fraction, Pad Profile, 
Radial Distribution of Pressure (Film Thickness), 
Radial Distribution of Pressure (Angular Speed), 
Circumferential Distribution of Pressure (Film Thickness), 
Circumferential Distribution of Pressure (Angular Speed), and Lift Force.

2 Right-click and choose Group.

Initial Design
In the Settings window for Group, type Initial Design in the Label text field.

Circumferential Distribution of Pressure (Shape Optimization), Fluid Pressure, Shape 
Optimization (hdb), Mass Fraction, Shape Optimization, Mesh, Pad Profile, Shape 
Optimization, Pressure, Shape Optimization (Height), Radial Distribution of Pressure 
(Shape Optimization), Shape Optimization
1 In the Model Builder window, under Results, Ctrl-click to select Fluid Pressure,

Shape Optimization (hdb), Pressure, Shape Optimization (Height), Mass Fraction,

Shape Optimization, Pad Profile, Shape Optimization, 
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Radial Distribution of Pressure (Shape Optimization), 
Circumferential Distribution of Pressure (Shape Optimization), Mesh, and 
Shape Optimization.

2 Right-click and choose Group.

Shape Optimization
In the Settings window for Group, type Shape Optimization in the Label text field.

Study: Shape Optimization/Solution 2 (sol2)
The optimization study is now completed. Next, remesh the optimized configuration and 
recompute the pressure profile and compare it with the optimized results. Start by 
generating the mesh for the deformed configuration.

In the Results toolbar, click Attributes and choose Remesh Deformed Configuration.

Add a new study for verification.

A D D  S T U D Y

1 In the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select General Studies>Stationary.

4 Find the Physics interfaces in study subsection. In the table, clear the Solve check boxes 
for Coefficient Form Boundary PDE (cb) and Coefficient Form Edge PDE (ce).

5 Click Add Study in the window toolbar.

6 In the Home toolbar, click Add Study to close the Add Study window.

S T U D Y :  R E M E S H  A N D  V E R I F Y

1 In the Model Builder window, click Study 3.

2 In the Settings window for Study, type Study: Remesh and Verify in the Label text 
field.

3 Locate the Study Settings section. Clear the Generate default plots check box.

Step 1: Stationary
1 In the Model Builder window, under Study: Remesh and Verify click Step 1: Stationary.

2 In the Settings window for Stationary, click to expand the Results While Solving section.

3 From the Probes list, choose None.
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4 Click to expand the Values of Dependent Variables section. Find the 
Values of variables not solved for subsection. From the Settings list, choose 
User controlled.

5 From the Method list, choose Solution.

6 From the Study list, choose Study: Shape Optimization, Stationary.

7 In the Home toolbar, click Compute.

Follow the instructions below to compare the results of the optimization study with the 
solution on the optimized configuration.

R E S U L T S

Verification
1 In the Home toolbar, click Add Plot Group and choose 3D Plot Group.

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Dataset list, choose Study: Remesh and Verify/Solution 3 (sol3).

4 In the Label text field, type Verification.

Surface 1
Right-click Verification and choose Surface.

Marker 1
1 In the Model Builder window, right-click Surface 1 and choose Marker.

2 In the Settings window for Marker, locate the Text Format section.

3 In the Display precision text field, type 4.

Surface 2
1 In the Model Builder window, under Results>Verification right-click Surface 1 and choose 

Duplicate.

2 In the Settings window for Surface, locate the Data section.

3 From the Dataset list, choose Study: Shape Optimization/Solution 2 (sol2).

Translation 1
1 Right-click Surface 2 and choose Translation.

2 In the Settings window for Translation, locate the Translation section.

3 In the x text field, type 0.2.

4 In the Verification toolbar, click Plot.
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Surface 2
1 In the Model Builder window, click Surface 2.

2 In the Settings window for Surface, click to expand the Inherit Style section.

3 From the Plot list, choose Surface 1.

4 In the Verification toolbar, click Plot.

5 Click the Go to Default View button in the Graphics toolbar.

R O O T

You can now optimize the pad shapes for different numbers of pads in the bearings. Add 
a new study with shape optimization and a parametric sweep over the number of pads.

A D D  S T U D Y

1 In the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select General Studies>Stationary.

4 Click Add Study in the window toolbar.

5 In the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  4

Step 1: Stationary
1 In the Settings window for Stationary, locate the Results While Solving section.

2 From the Probes list, choose None.

Shape Optimization
1 In the Study toolbar, click Optimization and choose Shape Optimization.

2 In the Settings window for Shape Optimization, locate the Optimization Solver section.

3 In the Maximum number of iterations text field, type 15.

4 Click Replace Expression in the upper-right corner of the Objective Function section. 
From the menu, choose Component 1 (comp1)>Hydrodynamic Bearing>Fluid loads>

Fluid load on collar (spatial and material frames) - N>comp1.hdb.htb1.Fcz -

Fluid load on collar, z component.

5 Locate the Objective Function section. From the Type list, choose Maximization.

6 From the Objective scaling list, choose Initial solution based.

7 Locate the Output While Solving section. From the Probes list, choose None.
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Parametric Sweep
1 In the Study toolbar, click Parametric Sweep.

2 In the Settings window for Parametric Sweep, locate the Study Settings section.

3 Click Add.

4 In the table, enter the following settings:

5 Locate the Output While Solving section. From the Probes list, choose None.

6 In the Model Builder window, click Study 4.

7 In the Settings window for Study, type Study: Shape Optimization Sweep in the 
Label text field.

8 Locate the Study Settings section. Clear the Generate default plots check box.

Solution 4 (sol4)
1 In the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 4 (sol4) node, then click 
Optimization Solver 1.

3 In the Settings window for Optimization Solver, locate the Optimization Solver section.

4 Clear the Globally Convergent MMA check box.

5 Locate the Advanced section. From the Compensate for nojac terms list, choose Off.

6 In the Study toolbar, click Compute.

R E S U L T S

Shape Optimization Sweep
1 In the Model Builder window, right-click Shape Optimization and choose Duplicate.

2 In the Settings window for 3D Plot Group, type Shape Optimization Sweep in the 
Label text field.

3 Locate the Data section. From the Dataset list, choose Study: Shape Optimization Sweep/

Parametric Solutions 1 (sol5).

4 From the Parameter value (N) list, choose 4.

5 In the Shape Optimization Sweep toolbar, click Plot.

Objective vs Number of Pads
1 In the Home toolbar, click Add Plot Group and choose 1D Plot Group.

Parameter name Parameter value list Parameter unit

N (Number of pads) 4 5 6
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2 In the Settings window for 1D Plot Group, type Objective vs Number of Pads in the 
Label text field.

3 Locate the Data section. From the Dataset list, choose Study: Shape Optimization Sweep/

Parametric Solutions 1 (sol5).

Global 1
1 Right-click Objective vs Number of Pads and choose Global.

2 In the Settings window for Global, click Add Expression in the upper-right corner of the 
y-Axis Data section. From the menu, choose Component 1 (comp1)>

Hydrodynamic Bearing>Fluid loads>Fluid load on collar (spatial and material frames) - N>

hdb.htb1.Fcz - Fluid load on collar, z component.

3 In the Objective vs Number of Pads toolbar, click Plot.

4 Locate the y-Axis Data section. In the table, enter the following settings:

5 Click to expand the Legends section. Clear the Show legends check box.

6 In the Objective vs Number of Pads toolbar, click Plot.

Duplicate the Shape Optimization plot once again to generate the thumbnail for the model.

Thumbnail
1 In the Model Builder window, right-click Shape Optimization and choose Duplicate.

2 In the Settings window for 3D Plot Group, type Thumbnail in the Label text field.

3 Right-click Thumbnail and choose Move Out.

4 Right-click Thumbnail and choose Move Down.

5 Right-click Thumbnail and choose Move Down.

Surface 1
1 In the Model Builder window, expand the Thumbnail node.

2 Right-click Results>Thumbnail>Surface 1 and choose Delete.

Line 1
1 In the Model Builder window, under Results>Thumbnail click Line 1.

2 In the Settings window for Line, locate the Coloring and Style section.

3 From the Line type list, choose Tube.

4 In the Tube radius expression text field, type 4e-4.

Expression Unit Description

hdb.htb1.Fcz kN Fluid load on collar, z component
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5 Select the Radius scale factor check box.

Line 2
1 Right-click Results>Thumbnail>Line 1 and choose Duplicate.

2 In the Settings window for Line, locate the Coloring and Style section.

3 From the Color list, choose Black.

Deformation 1
1 In the Model Builder window, expand the Line 2 node.

2 Right-click Results>Thumbnail>Line 2>Deformation 1 and choose Delete.

Thumbnail
1 Click the Go to XY View button in the Graphics toolbar.

2 Click the Zoom In button in the Graphics toolbar.
25 |  S H A P E  O P T I M I Z A T I O N  O F  A  S T E P  T H R U S T  B E A R I N G



26 |  S H A P E  O P T I M I Z A T I O N  O F  A  S T E P  T H R U S T  B E A R I N G


	Shape Optimization of a Step Thrust Bearing
	Introduction
	Model Definition
	Results and Discussion
	Modeling Instructions


