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Introduction

Impedance tubes are used for characterizing poroacoustic materials, usually with a focus 
on a frequency-dependent surface impedance. Alternatively, it is possible to assume a 
poroacoustic model and estimate the associated (frequency-independent) material 
parameters. This model uses a Johnson–Champoux–Allard material to generate synthetic 
data for two different meshes. This ensures that the data noise is dominated by the 
explicitly added noise rather than that of the mesh. The material parameters are taken from 
Ref. 1, and they are recovered based on the real and imaginary parts of the pressure at two 
probes (microphones). The generation of synthetic data and recovery of material 
parameters is a good sanity test, which can indicate the level of achievable accuracy given 
a certain experimental measurement error.

Model Definition

The model geometry (Figure 1) consists of two regions: the tube filled with air above a 
domain for the porous material (the test sample).

Figure 1: The model geometry.
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The pressure in the top of the tube is described using a linear elastic pressure acoustics 
model, while the bottom is governed by the Johnson–Champoux–Allard model (using the 
Poroacoustics domain feature). The tube is exited using Normal Acceleration on the top 
boundary. The model makes use of axisymmetry and the azimuthal mode number is fixed 
at 0 as illustrated in Figure 2.

Figure 2: The sound pressure level is plotted for a frequency of 4 KHz. 
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Results and Discussion

Figure 3 shows the relative difference between using 18 and 36 elements per wavelength. 
Since the difference is smaller than 0.1 %, we add 0.5 % (normally distributed) noise to the 
data generated with 18 elements per wavelength.

Figure 3: The relative difference between using 18 and 36 elements per (minimum) 
wavelength.

The relative errors on the estimated parameters are 0.0008%, 0.6%, 3.5%, 1.9%, and 0.2% 
for the flow resistivity, thermal characteristic length, viscous characteristic length, 
tortuosity factor, and porosity, respectively. These values will be larger if more noise is 
added to the generated data, but if less noise is added the accuracy of the estimation might 
be limited by the mesh resolution. This effect might not be observable unless different 
meshes are used for generating the data and recovering the parameters.
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The generated pressure data with 1% noise is compared with the fitted values in Figure 4.

Figure 4: The real and imaginary parts of the pressure compared with the generated data for 
sensor 4.

Reference

1. Multilayered Porous Material: Poroelastic Waves with Thermal and Viscous Losses 
(Biot-Allard Model), https://www.comsol.com/model/34531

Notes About the COMSOL Implementation

This model combines the Optimization and Pressure Acoustics interfaces. Splitting of 
complex variables into real and imaginary parts is enabled in the Compile Equations step 
in the optimization study. The generated data is imported using a Global Least-Squares 
Objective, and subnodes are added in the order corresponding to the column in the file. 
The Levenberg–Marquardt optimizer is used to solve the optimization problem with the 
frequencies automatically taken from the file. Global Evaluation groups as well as Global 
plots make use of the withsol operator to combine data from different solutions.
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Application Library path: Optimization_Module/Parameter_Estimation/
impedance_tube_parameter_estimation_data

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D Axisymmetric.

2 In the Select Physics tree, select Acoustics>Pressure Acoustics>Pressure Acoustics,

Frequency Domain (acpr).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select General Studies>Frequency Domain.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Add four parameter sets: One each for the geometry, the material, the initial guess material 
parameters, and miscellaneous parameters. Alternatively, you can load the parameters from 
the file impedance_tube_parameter_estimation_data_parameters.txt in the 
model’s Application Libraries folder.

Geometrical Parameters
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, type Geometrical Parameters in the Label text 
field.

3 Locate the Parameters section. In the table, enter the following settings:

Name Expression Value Description

L1 30[cm] 0.3 m Length of tube

D1 10[cm] 0.1 m Diameter of tube
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Material Parameters
1 In the Home toolbar, click Parameters and choose Add>Parameters.

2 In the Settings window for Parameters, type Material Parameters in the Label text 
field.

3 Locate the Parameters section. In the table, enter the following settings:

Material Parameters (Initial Guess)
1 In the Home toolbar, click Parameters and choose Add>Parameters.

2 In the Settings window for Parameters, type Material Parameters (Initial Guess) 
in the Label text field.

3 Locate the Parameters section. In the table, enter the following settings:

Parameters 4
1 In the Home toolbar, click Parameters and choose Add>Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

L2 3[cm] 0.03 m Length of porous region

L3 2[cm] 0.02 m Microphone spacing

Name Expression Value Description

Rf0 87[kN*s/m^4] 87000 N·s/(m·m³) Flow resistivity

Lth0 119[um] 1.19E-4 m Thermal characteristic 
length

Lv0 37[um] 3.7E-5 m Viscous characteristic 
length

tau0 2.52 2.52 Tortuosity factor

epsilon0 0.97 0.97 Porosity

Name Expression Value Description

Rf1 100[kN*s/m^4] 1E5 N·s/(m·m³) Flow resistivity

Lth1 100[um] 1E-4 m Thermal characteristic 
length

Lv1 100[um] 1E-4 m Viscous characteristic 
length

tau1 1 1 Tortuosity factor

epsilon1 0.5 0.5 Porosity

Name Expression Value Description
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3 In the table, enter the following settings:

G E O M E T R Y  1

Use the parameters to define the geometry.

Rectangle 1 (r1)
1 In the Geometry toolbar, click Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type D1/2.

4 In the Height text field, type L1.

5 Locate the Position section. In the z text field, type L2.

Rectangle 2 (r2)
1 In the Geometry toolbar, click Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type D1/2.

4 In the Height text field, type L2.

Point 1 (pt1)
1 In the Geometry toolbar, click Point.

2 In the Settings window for Point, locate the Point section.

3 In the r text field, type D1/2.

4 In the z text field, type L2+L3.

5 Locate the Selections of Resulting Entities section. Select the Resulting objects selection 
check box.

Point 2 (pt2)
1 In the Geometry toolbar, click Point.

2 In the Settings window for Point, locate the Point section.

3 In the r text field, type D1/2.

Name Expression Value Description

error 5e-3 0.005 Relative measurement 
error

fmin 500[Hz] 500 Hz Minimum frequency

fmax 4[kHz] 4000 Hz Maximum frequency

meshsz 340[m/s]/fmax/12 0.0070833 m Mesh size
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4 In the z text field, type L2+2*L3.

5 Locate the Selections of Resulting Entities section. Select the Resulting objects selection 
check box.

6 Click Build Selected.

7 In the Graphics window toolbar, click next to Select Objects, then choose 
Select Points.

8 Click the Zoom Extents button in the Graphics toolbar.

Define a Random function to simulate noise. Then add probes for the two pressure sensors.

G L O B A L  D E F I N I T I O N S

Random 1 (rn1)
1 In the Home toolbar, click Functions and choose Global>Random.

2 In the Settings window for Random, locate the Parameters section.

3 From the Distribution list, choose Normal.

D E F I N I T I O N S

Microphone 1 (real)
1 In the Definitions toolbar, click Probes and choose Point Probe.

2 In the Settings window for Point Probe, type Microphone 1 (real) in the Label text 
field.

3 In the Variable name text field, type mic1_real.

4 Locate the Source Selection section. From the Selection list, choose Point 1.

5 Locate the Expression section. In the Expression text field, type real(acpr.p_t).

Microphone 1 (imag)
1 Right-click Microphone 1 (real) and choose Duplicate.

2 In the Settings window for Point Probe, type Microphone 1 (imag) in the Label text 
field.

3 In the Variable name text field, type mic1_imag.

4 Locate the Expression section. In the Expression text field, type imag(acpr.p_t).

Microphone 2 (real)
1 In the Model Builder window, under Component 1 (comp1)>Definitions right-click 

Microphone 1 (real) (mic1_real) and choose Duplicate.
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2 In the Settings window for Point Probe, type Microphone 2 (real) in the Label text 
field.

3 In the Variable name text field, type mic2_real.

4 Locate the Source Selection section. From the Selection list, choose Point 2.

Microphone 2 (imag)
1 Right-click Microphone 2 (real) and choose Duplicate.

2 In the Settings window for Point Probe, type Microphone 2 (imag) in the Label text 
field.

3 In the Variable name text field, type mic2_imag.

4 Locate the Expression section. In the Expression text field, type imag(acpr.p_t).

A D D  M A T E R I A L

1 In the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-in>Air.

4 Click Add to Component in the window toolbar.

5 In the Home toolbar, click Add Material to close the Add Material window.

M A T E R I A L S

Material 2 (mat2)
In the Model Builder window, under Component 1 (comp1) right-click Materials and choose 
Blank Material.

P R E S S U R E  A C O U S T I C S ,  F R E Q U E N C Y  D O M A I N  ( A C P R )

Add four parameter sets: One each for the geometry, the material, the initial guess material 
parameters, and miscellaneous parameters. Alternatively, you can load the parameters from 
the file impedance_tube_parameter_estimation_data_parameters.txt in the 
model’s Application Libraries folder.

Poroacoustics 1
1 In the Model Builder window, expand the Material 2 (mat2) node.

2 Right-click Component 1 (comp1)>Pressure Acoustics, Frequency Domain (acpr) and 
choose Poroacoustics.

3 Select Domain 1 only.

4 In the Settings window for Poroacoustics, locate the Poroacoustics Model section.
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5 From the Poroacoustics model list, choose Johnson-Champoux-Allard (JCA).

6 Locate the Porous Matrix Properties section. From the Porous elastic material list, choose 
Material 2 (mat2).

Normal Acceleration 1
1 In the Physics toolbar, click Boundaries and choose Normal Acceleration.

2 Select Boundary 5 only.

3 In the Settings window for Normal Acceleration, locate the Normal Acceleration section.

4 In the an text field, type 1.

M A T E R I A L S

Material 2 (mat2)
1 In the Model Builder window, under Component 1 (comp1)>Materials click 

Material 2 (mat2).

2 In the Settings window for Material, locate the Material Contents section.

3 In the table, enter the following settings:

M E S H  1

Free Triangular 1
In the Mesh toolbar, click Free Triangular.

Size
1 In the Model Builder window, click Size.

2 In the Settings window for Size, locate the Element Size section.

3 Click the Custom button.

Property Variable Value Unit Property group

Porosity epsilon epsilon0 1 Basic

Viscous 
characteristic length

Lv Lv0 m Poroacoustics 
model

Thermal 
characteristic length

Lth Lth0 m Poroacoustics 
model

Tortuosity factor tau tau0 1 Poroacoustics 
model

Flow resistivity Rf Rf0 Pa·s/m² Poroacoustics 
model
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4 Locate the Element Size Parameters section. In the Maximum element size text field, type 
meshsz.

5 In the Minimum element size text field, type meshsz/2.

6 In the Model Builder window, right-click Mesh 1 and choose Build All.

G E N E R A T E  E X P E R I M E N T A L  D A T A

1 In the Model Builder window, click Study 1.

2 In the Settings window for Study, type Generate Experimental Data in the Label text 
field.

Parametric Sweep
1 In the Study toolbar, click Parametric Sweep.

2 In the Settings window for Parametric Sweep, locate the Study Settings section.

3 Click Add.

4 In the table, enter the following settings:

5 Locate the Output While Solving section. From the Probes list, choose None.

Step 1: Frequency Domain
1 In the Model Builder window, click Step 1: Frequency Domain.

2 In the Settings window for Frequency Domain, click to expand the Results While Solving 
section.

3 From the Probes list, choose None.

4 Locate the Study Settings section. Click Range.

5 In the Range dialog box, choose ISO preferred frequencies from the Entry method list.

6 In the Start frequency text field, type fmin.

7 In the Stop frequency text field, type fmax.

8 From the Interval list, choose 1/24 octave.

9 Click Replace.

10 In the Study toolbar, click Compute.

Parameter name Parameter value list Parameter unit

meshsz (Mesh size) 7 3.5 mm
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R E S U L T S

Sound Pressure Level, 3D (acpr)
1 In the Model Builder window, under Results click Sound Pressure Level, 3D (acpr).

2 In the Sound Pressure Level, 3D (acpr) toolbar, click Plot.

3 Click the Zoom Extents button in the Graphics toolbar.

Acoustic Pressure (acpr), Acoustic Pressure, 3D (acpr), Sound Pressure Level (acpr), 
Sound Pressure Level, 3D (acpr)
1 In the Model Builder window, under Results, Ctrl-click to select Acoustic Pressure (acpr), 

Sound Pressure Level (acpr), Acoustic Pressure, 3D (acpr), and Sound Pressure Level,

3D (acpr).

2 Right-click and choose Group.

Experimental Data
In the Settings window for Group, type Experimental Data in the Label text field.

Experimental Data
1 In the Results toolbar, click Evaluation Group.

2 In the Settings window for Evaluation Group, type Experimental Data in the Label text 
field.

Generate the experimental data using the probes and the random error function. You can 
import the table contents from 
impedance_tube_parameter_estimation_data_pressure.txt.

Global Evaluation 1
1 Right-click Experimental Data and choose Global Evaluation.

2 In the Settings window for Global Evaluation, locate the Expressions section.

3 In the table, enter the following settings:

4 In the Experimental Data toolbar, click Evaluate.

The error due to the mesh should be smaller than the added error. To check if this is the 
case, investigate the effect of mesh refinement for the measured pressure.

Expression Unit Description

mic1_real*(1+error*rn1(freq+0)) Pa Sensor 1, real

mic1_imag*(1+error*rn1(freq+1)) Pa Sensor 1, imaginary

mic2_real*(1+error*rn1(2*freq+0)) Pa Sensor 2, real

mic2_imag*(1+error*rn1(2*freq+1)) Pa Sensor 2, imaginary
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Relative Errors (mesh)
1 In the Results toolbar, click Evaluation Group.

2 In the Settings window for Evaluation Group, locate the Data section.

3 From the Dataset list, choose Generate Experimental Data/Parametric Solutions 1 (sol2).

4 From the Parameter selection (meshsz) list, choose First.

5 In the Label text field, type Relative Errors (mesh).

Compute the relative errors of the measured pressures. Use the magnitude to avoid spikes 
when the real and imaginary parts go through zero.

Global Evaluation 1
1 Right-click Relative Errors (mesh) and choose Global Evaluation.

2 In the Settings window for Global Evaluation, locate the Expressions section.

3 Click Clear Table.

4 Click Load from File.

5 Browse to the model’s Application Libraries folder and double-click the file 
impedance_tube_parameter_estimation_data_errors_mesh.txt.

6 In the Relative Errors (mesh) toolbar, click Evaluate.

Errors
1 In the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Errors in the Label text field.

Table Graph 1
1 Right-click Errors and choose Table Graph.

2 In the Settings window for Table Graph, locate the Data section.

3 From the Source list, choose Evaluation group.

4 From the Evaluation group list, choose Relative Errors (mesh).

5 From the x-axis data list, choose freq (Hz).

6 From the Plot columns list, choose Manual.

7 In the Columns list, choose Sensor 1, magnitude (1) and Sensor 2, magnitude (1).

8 Click to expand the Legends section. Select the Show legends check box.

Errors
1 In the Model Builder window, click Errors.

2 In the Settings window for 1D Plot Group, locate the Plot Settings section.
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3 Select the x-axis label check box. In the associated text field, type Frequency (Hz).

4 Select the y-axis label check box. In the associated text field, type Relative error.

5 Locate the Legend section. From the Position list, choose Upper left.

6 In the Errors toolbar, click Plot.

7 Click the Zoom Extents button in the Graphics toolbar.

The error due to the mesh is an order of magnitude smaller than the added error, so the 
mesh is sufficiently fine. It is thus safe to export the table.

Table 1
1 In the Results toolbar, click Data and choose Table.

2 In the Settings window for Table, locate the Table section.

3 From the Source list, choose Evaluation group.

4 Locate the Output section. In the Filename text field, type 
impedance_tube_parameter_estimation_data.csv.

5 Click to expand the Layout section. Clear the Include header check box.

6 Click Export.

R O O T

Add a second study for the parameter estimation.

A D D  S T U D Y

1 In the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select General Studies>

Frequency Domain.

4 Click Add Study in the window toolbar.

5 In the Home toolbar, click Add Study to close the Add Study window.

P A R A M E T E R  E S T I M A T I O N

1 In the Model Builder window, click Study 2.

2 In the Settings window for Study, type Parameter Estimation in the Label text field.

Parameter Estimation
1 In the Study toolbar, click Optimization and choose Parameter Estimation.

2 In the Settings window for Parameter Estimation, locate the Experimental Data section.
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3 In the Filename text field, type impedance_tube_parameter_estimation_data.csv.

4 Click Import.

5 Locate the Column Settings section. In the table, click to select the cell at row number 2 
and column number 2.

6 In the table, enter the following settings:

7 In the Model expression text field, type comp1.mic1_real.

8 In the Name text field, type pressure1.

9 In the Unit text field, type Pa.

10 In the table, click to select the cell at row number 3 and column number 3.

11 In the Model expression text field, type comp1.mic1_imag.

12 In the Name text field, type pressure2.

13 In the Unit text field, type Pa.

14 In the table, click to select the cell at row number 4 and column number 3.

15 In the Model expression text field, type comp1.mic2_real.

16 In the Name text field, type pressure3.

17 In the Unit text field, type Pa.

18 In the table, click to select the cell at row number 5 and column number 3.

19 In the Model expression text field, type comp1.mic2_imag.

20 In the Name text field, type pressure4.

21 In the Unit text field, type Pa.

22 Locate the Parameter Estimation Method section. From the Method list, choose 
Levenberg-Marquardt.

23 Find the Solver settings subsection. From the Least-squares time/parameter method list, 
choose From least-squares objective.

24 Click to expand the Output While Solving section. From the Probes list, choose None.

Columns Type Settings

Column 1 Frequency Frequency unit=Hz

Column 2 Value Model expression=comp1.mic1_real, Name=col2, 
Weight=1

Column 3 Value Model expression=1, Name=col3, Weight=1

Column 4 Value Model expression=1, Name=col4, Weight=1

Column 5 Value Model expression=1, Name=col5, Weight=1
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25 Locate the Column Settings section. In the table, click to select the cell at row number 2 
and column number 2.

26 Locate the Parameter Estimation Method section. From the Method list, choose 
Levenberg-Marquardt.

27 From the Least-squares time/parameter method list, choose From least-squares objective.

28 Locate the Parameters section. Click Add five times.

29 In the table, enter the following settings:

30 Click to expand the Output While Solving section. From the Probes list, choose None.

Solution 5 (sol5)
1 In the Study toolbar, click Show Default Solver to initialize the solver so that the 

splitting of complex variables can be enabled.

2 In the Model Builder window, expand the Solution 5 (sol5) node, then click 
Compile Equations: Frequency Domain.

3 In the Settings window for Compile Equations, locate the Study and Step section.

4 Select the Split complex variables in real and imaginary parts check box.

5 In the Model Builder window, under Parameter Estimation>Solver Configurations>

Solution 5 (sol5) click Optimization Solver 1.

6 In the Settings window for Optimization Solver, locate the Optimization Solver section.

7 From the Gradient method list, choose Adjoint to make the sensitivity analysis a bit faster.

Step 1: Frequency Domain
1 In the Model Builder window, under Parameter Estimation click 

Step 1: Frequency Domain.

2 In the Settings window for Frequency Domain, click to expand the Mesh Selection section.

Parameter name Initial value Scale Lower 
bound

Upper 
bound

epsilon0 (Porosity) epsilon1 1

Lth0 (Thermal characteristic 
length)

Lth1 100[um]

Lv0 (Viscous characteristic length) Lv1 100[um]

Rf0 (Flow resistivity) Rf1 100[kN*s/
m^4]

tau0 (Tortuosity factor) tau1 1
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3 In the table, enter the following settings:

4 In the Study toolbar, click Compute.

R E S U L T S

Acoustic Pressure (acpr) 1, Acoustic Pressure, 3D (acpr) 1, Parameter estimation, Sound 
Pressure Level (acpr) 1, Sound Pressure Level, 3D (acpr) 1
1 In the Model Builder window, under Results, Ctrl-click to select 

Acoustic Pressure (acpr) 1, Sound Pressure Level (acpr) 1, Acoustic Pressure, 3D (acpr) 1, 
Sound Pressure Level, 3D (acpr) 1, and Parameter estimation.

2 Right-click and choose Group.

Parameter Estimation
In the Settings window for Group, type Parameter Estimation in the Label text field.

Add two 1D plot groups for comparing the noisy exported pressures with the fitted 
pressures.

Parameter estimation
1 In the Model Builder window, click Parameter estimation.

2 In the Parameter estimation toolbar, click Plot.

3 Click the Zoom Extents button in the Graphics toolbar.

Relative Errors
1 In the Results toolbar, click Evaluation Group.

2 In the Settings window for Evaluation Group, type Relative Errors in the Label text 
field.

3 Locate the Data section. From the Dataset list, choose Parameter Estimation/

Solution 5 (sol5).

4 From the Parameter selection (freq) list, choose First.

Compute the relative errors of the fitted material parameters. You can import the table 
contents from impedance_tube_parameter_estimation_errors_parameters.txt.

Global Evaluation 1
1 Right-click Relative Errors and choose Global Evaluation.

2 In the Settings window for Global Evaluation, locate the Expressions section.

Component Mesh

Component 1 Mesh 1
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3 In the table, enter the following settings:

4 In the Relative Errors toolbar, click Evaluate.

Expression Unit Description

abs(Rf0-withsol('sol1',Rf0))/withsol('sol1',
Rf0)

1

abs(Lth0-withsol('sol1',Lth0))/
withsol('sol1',Lth0)

1

abs(Lv0-withsol('sol1',Lv0))/withsol('sol1',
Lv0)

1

abs(tau0-withsol('sol1',tau0))/
withsol('sol1',tau0)

1

abs(epsilon0-withsol('sol1',epsilon0))/
withsol('sol1',epsilon0)

1
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