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Introduction

This model demonstrates alternative implementations for describing a thin layer, and the 
impact of the choice on the continuity of the displacement and stress fields. It is shown 
how a perfect interface can be obtained by asymptotically changing the material 
parameters.

Model Definition

Figure 1 shows the undeformed geometry composed by two domains forming a square of 
side L and the contacting surface where the thin layer interface will be placed. The full 
domain is a square of side 1 m and the interface is built by joining two circular arcs of 
radius 0.707.

Figure 1: Model geometry.

A nearly incompressible Saint Venant–Kirchhoff hyperelastic material is used for both 
domains. The thin layer of thickness d << L contains a compressible Saint Venant–
Kirchhoff hyperelastic material. The domain material properties are shown in Table 1.

TABLE 1:  DOMAIN MATERIAL PROPERTIES.

VARIABLE VALUE

Bulk modulus 50 N/mm2

Shear modulus 10 N/mm2
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T H I N  L A Y E R  A P P R O X I M A T I O N S

This study uses three approximations:

• Solid

• Membrane

• Spring

In the solid approximation, a slit is introduced and consequently a discontinuity of the 
displacement field is allowed. The slit is filled with a 3D thin material whose deformation 
gradient, F, is approximated as

 (1)

Here, ue is the extension of the layer, ua is the average displacement of the layer mid-
plane, and N is the normal.

In the membrane approximation, no slit is introduced; the continuity of the displacement 
is assured and only a jump in the stress is permitted. The deformation gradient is 
approximated as follows:

 (2)

The material properties for both the solid and membrane approximations are given in 
terms of the bulk modulus kb and the shear modulus μb.

If a spring material is used, a slit is introduced as in the solid case and the two sides of the 
interface are connected by springs. The deformation gradient is approximated as

 (3)

and the resulting geometric nonlinear spring force fs per unit area is defined as

 (4)

where α is the spring stiffness constant.

B O U N D A R Y  C O N D I T I O N S

A prescribed displacement boundary condition is applied on the lateral faces in the normal 
direction up to a stretch of 50%. The upper and lower faces are constrained with a roller.
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Results and Discussion

In the case of a perfect interface, the displacement and stresses are continuous, as shown 
in Figure 2.

Figure 2: First Piola-Kirchhoff stress (xX component) for the perfect interface case after a 50% 
stretch. Continuity of displacements and stresses along the interface are enforced.

If a thin layer of material is inserted between the domains, the perfect continuity of the 
stress and displacements is no longer ensured. For example, when using a solid 
approximation, both the stress and displacement fields are discontinuous, as shown in 
Figure 3.
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Figure 3: First Piola–Kirchhoff stress distribution with a thin layer using a solid 
approximation.

The displacement can be enforced to be continuous using the membrane approximation. 
Moreover, if the ratio between the shear modulus of the thin layer and the bulk material 
goes to zero, the continuity of the stress is also restored.
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Figure 4: First Piola–Kirchhoff stress distribution with a thin layer using the membrane 
approximation.
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Figure 5: Stress at the center point. Comparison between thin layer (membrane 
approximation) and perfect interface.

If a spring material is used, the displacements are no more continuous but the stresses are. 
If the stiffness of the spring increases, the displacement jump disappears resulting in a 
perfect interface.
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Figure 6: First Piola–Kirchhoff stress distribution with a thin layer using a spring material.
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Figure 7: Stress at the center point. Comparison between thin layer (spring material) and 
perfect interface.
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Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D.
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2 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

3 Click Add.

4 Click Study.

5 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters: Geometry
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, type Parameters: Geometry in the Label text 
field.

3 Locate the Parameters section. In the table, enter the following settings:

Parameters: Bulk Material
1 In the Home toolbar, click Parameters and choose Add>Parameters.

2 In the Settings window for Parameters, type Parameters: Bulk Material in the Label 
text field.

3 Locate the Parameters section. In the table, enter the following settings:

Parameters: Thin Layer
1 In the Home toolbar, click Parameters and choose Add>Parameters.

2 In the Settings window for Parameters, type Parameters: Thin Layer in the Label text 
field.

Name Expression Value Description

L 1[m] 1 m Length

R 1[m]/sqrt(2) 0.70711 m Radius

d 1[m] 1 m Out-of-Plane dimension

Name Expression Value Description

RhoBulk 1[kg/m^3] 1 kg/m³ Density

KBulk 50 [N/mm^2] 5E7 N/m² Bulk Modulus

MuBulk 10 [N/mm^2] 1E7 N/m² Lame Parameter
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3 Locate the Parameters section. In the table, enter the following settings:

Parameters: Boundary Conditions
1 In the Home toolbar, click Parameters and choose Add>Parameters.

2 In the Settings window for Parameters, type Parameters: Boundary Conditions in 
the Label text field.

3 Locate the Parameters section. In the table, enter the following settings:

Parameters: Mesh
1 In the Home toolbar, click Parameters and choose Add>Parameters.

2 In the Settings window for Parameters, type Parameters: Mesh in the Label text field.

3 Locate the Parameters section. In the table, enter the following settings:

G E O M E T R Y  1

Square 1 (sq1)
1 In the Model Builder window, expand the Component 1 (comp1)>Geometry 1 node.

2 Right-click Geometry 1 and choose Square.

3 In the Settings window for Square, locate the Size section.

Name Expression Value Description

th L/10 0.1 m Thin layer thickness

RhoBnd 1[kg/m^3] 1 kg/m³ Density

KRatio 0.2 0.2 Scale factor for bulk 
modulus

KBnd KRatio*KBulk 1E7 N/m² Bulk modulus

MuRatio 100 100 Scale factor for Lame 
parameter

MuBnd MuRatio*MuBulk 1E9 N/m² Lame parameter

AlphaRatio 1 1 Scale factor for 
stiffness

AlphaBnd AlphaRatio*(KBulk/
th)

5E8 N/m³ Spring stiffness

Name Expression Value Description

stretch 0 0 Stretch

Name Expression Value Description

nel 20 20 Number of elements
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4 In the Side length text field, type L.

Circular Arc 1 (ca1)
1 In the Geometry toolbar, click More Primitives and choose Circular Arc.

2 In the Settings window for Circular Arc, locate the Radius section.

3 In the Radius text field, type R.

4 Locate the Angles section. In the End angle text field, type 45.

Circular Arc 2 (ca2)
1 Right-click Circular Arc 1 (ca1) and choose Duplicate.

2 In the Settings window for Circular Arc, locate the Center section.

3 In the x text field, type L.

4 In the y text field, type L.

5 Locate the Angles section. In the Start angle text field, type 180.

6 In the End angle text field, type 225.

Partition Objects 1 (par1)
1 In the Geometry toolbar, click Booleans and Partitions and choose Partition Objects.

2 Select the object sq1 only.

3 In the Settings window for Partition Objects, locate the Partition Objects section.

4 Find the Tool objects subsection. Click to select the Activate Selection toggle 
button.

5 Select the objects ca1 and ca2 only.

Form Union (fin)
1 In the Geometry toolbar, click Build All.

2 In the Model Builder window, click Form Union (fin).

3 Select the object  only.

Add an average operator for plotting purposes.

D E F I N I T I O N S

Average 1 (aveop1)
1 In the Definitions toolbar, click Nonlocal Couplings and choose Average.

2 Click in the Graphics window and then press Ctrl+A to select both domains.
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S O L I D  M E C H A N I C S  ( S O L I D )

1 In the Model Builder window, expand the Component 1 (comp1)>Solid Mechanics (solid) 
node, then click Solid Mechanics (solid).

2 In the Settings window for Solid Mechanics, locate the Thickness section.

3 In the d text field, type d.

Hyperelastic Material 1
1 In the Physics toolbar, click Domains and choose Hyperelastic Material.

2 Click in the Graphics window and then press Ctrl+A to select both domains.

3 In the Settings window for Hyperelastic Material, locate the Hyperelastic Material section.

4 From the Material model list, choose St Venant-Kirchhoff.

5 From the Specify list, choose Bulk modulus and shear modulus.

6 From the Compressibility list, choose Nearly incompressible.

M A T E R I A L S

Bulk
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, type Bulk in the Label text field.

3 Locate the Material Contents section. In the table, enter the following settings:

S O L I D  M E C H A N I C S  ( S O L I D )

Roller 1
1 In the Physics toolbar, click Boundaries and choose Roller.

2 Select Boundaries 2–5 only.

Prescribed Displacement 1
1 In the Physics toolbar, click Boundaries and choose Prescribed Displacement.

2 Select Boundaries 1 and 6 only.

Property Variable Value Unit Property group

Bulk modulus K KBulk N/m² Bulk modulus and 
shear modulus

Shear modulus G MuBulk N/m² Bulk modulus and 
shear modulus

Density rho RhoBulk kg/m³ Basic
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3 In the Settings window for Prescribed Displacement, locate the 
Coordinate System Selection section.

4 From the Coordinate system list, choose Boundary System 1 (sys1).

5 Locate the Prescribed Displacement section. Select the Prescribed in t1 direction check 
box.

6 In the u0t1 text field, type 0.

7 Select the Prescribed in n direction check box.

8 In the u0n text field, type L*stretch/2.

M E S H  1

Mapped 1
In the Mesh toolbar, click Mapped.

Distribution 1
1 Right-click Mapped 1 and choose Distribution.

2 Select Boundaries 3, 5, 7, and 8 only.

3 In the Settings window for Distribution, locate the Distribution section.

4 In the Number of elements text field, type nel.

Distribution 2
1 In the Model Builder window, right-click Mapped 1 and choose Distribution.

2 In the Settings window for Distribution, locate the Distribution section.

3 From the Distribution type list, choose Predefined.

4 Select Boundary 2 only.

5 In the Number of elements text field, type nel.

6 In the Element ratio text field, type 3.

Distribution 3
1 Right-click Distribution 2 and choose Duplicate.

2 Select Boundary 4 only.

Distribution 4
1 In the Model Builder window, right-click Mapped 1 and choose Distribution.

2 Select Boundaries 1 and 6 only.

3 In the Settings window for Distribution, locate the Distribution section.

4 In the Number of elements text field, type nel*2.
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5 Click Build All.

A D D  S T U D Y

1 In the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select General Studies>Stationary.

4 Click Add Study in the window toolbar.

5 In the Home toolbar, click Add Study to close the Add Study window.

P E R F E C T  I N T E R F A C E

1 In the Model Builder window, click Study 1.

2 In the Settings window for Study, type Perfect Interface in the Label text field.

3 Locate the Study Settings section. Clear the Generate default plots check box.

Step 1: Stationary
1 In the Model Builder window, under Perfect Interface click Step 1: Stationary.

2 In the Settings window for Stationary, click to expand the Study Extensions section.

3 Select the Auxiliary sweep check box.

4 Click Add.

5 In the table, enter the following settings:

6 Click Range.

7 In the Range dialog box, type 0.1 in the Start text field.

8 In the Step text field, type 0.1.

9 In the Stop text field, type 0.5.

10 Click Replace.

11 In the Home toolbar, click Compute.

R E S U L T S

Perfect Interface
1 In the Model Builder window, expand the Results node.

2 Right-click Results and choose 2D Plot Group.

Parameter name Parameter value list Parameter unit

stretch (Stretch)
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3 In the Settings window for 2D Plot Group, type Perfect Interface in the Label text 
field.

4 Click to expand the Title section. From the Title type list, choose Manual.

5 In the Title text area, type Perfect Interface.

6 Clear the Parameter indicator text field.

Surface 1
1 Right-click Perfect Interface and choose Surface.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type solid.PxX.

4 From the Unit list, choose MPa.

Deformation 1
1 Right-click Surface 1 and choose Deformation.

2 In the Settings window for Deformation, locate the Scale section.

3 Select the Scale factor check box. In the associated text field, type 1.

4 In the Perfect Interface toolbar, click Plot.

5 Click the Zoom Extents button in the Graphics toolbar.

Add a thin layer between the domains using a solid approximation.

S O L I D  M E C H A N I C S  ( S O L I D )

Solid Approximation
1 In the Physics toolbar, click Boundaries and choose Thin Layer.

2 Select Boundaries 7 and 8 only.

3 In the Settings window for Thin Layer, locate the Boundary Properties section.

4 In the Lth text field, type th.

5 In the Label text field, type Solid Approximation.

Hyperelastic Material 1
1 In the Physics toolbar, click Attributes and choose Hyperelastic Material.

2 Select Boundaries 7 and 8 only.

3 In the Settings window for Hyperelastic Material, locate the Hyperelastic Material section.

4 From the Material model list, choose St Venant-Kirchhoff.

5 From the Specify list, choose Bulk modulus and shear modulus.
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M A T E R I A L S

Thin Layer
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, type Thin Layer in the Label text field.

3 Locate the Geometric Entity Selection section. From the Geometric entity level list, 
choose Boundary.

4 Select Boundaries 7 and 8 only.

5 Locate the Material Contents section. In the table, enter the following settings:

A D D  S T U D Y

1 In the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select General Studies>Stationary.

4 Click Add Study in the window toolbar.

5 In the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  2

Step 1: Stationary
1 In the Settings window for Stationary, click to expand the Study Extensions section.

2 Select the Auxiliary sweep check box.

3 Click Add.

4 In the table, enter the following settings:

5 Click Add.

Property Variable Value Unit Property group

Bulk modulus K KBnd N/m² Bulk modulus and 
shear modulus

Shear modulus G MuBnd N/m² Bulk modulus and 
shear modulus

Density rho RhoBnd kg/m³ Basic

Parameter name Parameter value list Parameter unit

stretch (Stretch) range(0.1,0.1,0.5)
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6 In the table, enter the following settings:

7 From the Sweep type list, choose All combinations.

8 From the Run continuation for list, choose Manual.

9 From the Continuation parameter list, choose stretch.

10 In the Model Builder window, click Study 2.

11 In the Settings window for Study, locate the Study Settings section.

12 Clear the Generate default plots check box.

13 In the Label text field, type Solid Approximation.

14 In the Home toolbar, click Compute.

R E S U L T S

Solid Approximation
1 In the Model Builder window, expand the Results node.

2 Right-click Results and choose 2D Plot Group.

3 In the Settings window for 2D Plot Group, type Solid Approximation in the Label text 
field.

4 Locate the Data section. From the Dataset list, choose Solid Approximation/

Solution 2 (sol2).

5 Click to expand the Title section. From the Title type list, choose Manual.

6 In the Title text area, type Thin Layer using Solid Thickness Approximation.

7 Clear the Parameter indicator text field.

Surface 1
1 Right-click Solid Approximation and choose Surface.

2 In the Settings window for Surface, locate the Data section.

3 From the Dataset list, choose Solid Approximation/Solution 2 (sol2).

4 From the Parameter value (MuRatio) list, choose 0.25.

5 Locate the Expression section. In the Expression text field, type solid.PxX.

6 From the Unit list, choose MPa.

7 In the Solid Approximation toolbar, click Plot.

Parameter name Parameter value list Parameter unit

MuRatio (Scale factor for Lame 
parameter)

range(1,-0.25,0.25) 0.01
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Deformation 1
1 In the Model Builder window, right-click Surface 1 and choose Deformation.

2 In the Settings window for Deformation, locate the Scale section.

3 Select the Scale factor check box. In the associated text field, type 1.

4 In the Solid Approximation toolbar, click Plot.

Arrow Line 1
In the Model Builder window, right-click Solid Approximation and choose Arrow Line.

Deformation 1
1 Right-click Arrow Line 1 and choose Deformation.

2 In the Settings window for Deformation, locate the Scale section.

3 Select the Scale factor check box. In the associated text field, type 1.

4 In the Solid Approximation toolbar, click Plot.

Arrow Line 1
1 In the Model Builder window, click Arrow Line 1.

2 In the Settings window for Arrow Line, locate the Arrow Positioning section.

3 From the Placement list, choose Mesh nodes.

4 Click Replace Expression in the upper-right corner of the Expression section. From the 
menu, choose Component 1 (comp1)>Solid Mechanics>Displacement>u,v -

Displacement field.

Selection 1
1 Right-click Arrow Line 1 and choose Selection.

2 Select Boundaries 1 and 6 only.

3 In the Solid Approximation toolbar, click Plot.

4 Click the Zoom Extents button in the Graphics toolbar.

Add a thin layer using a membrane approximation to get an elastic interface model.

C O M P O N E N T  1  ( C O M P 1 )

In the Model Builder window, expand the Component 1 (comp1) node.

S O L I D  M E C H A N I C S  ( S O L I D )

Membrane Approximation
1 In the Model Builder window, expand the Component 1 (comp1)>Solid Mechanics (solid) 

node.
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2 Right-click Solid Mechanics (solid) and choose Thin Layer.

3 In the Settings window for Thin Layer, type Membrane Approximation in the Label text 
field.

4 Select Boundaries 7 and 8 only.

5 Locate the Boundary Properties section. In the Lth text field, type th.

6 Locate the Thin Layer section. From the Approximation list, choose Membrane.

Hyperelastic Material 1
1 In the Physics toolbar, click Attributes and choose Hyperelastic Material.

2 Select Boundaries 7 and 8 only.

3 In the Settings window for Hyperelastic Material, locate the Hyperelastic Material section.

4 From the Material model list, choose St Venant-Kirchhoff.

5 From the Specify list, choose Bulk modulus and shear modulus.

A D D  S T U D Y

1 In the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select General Studies>Stationary.

4 Click Add Study in the window toolbar.

5 In the Home toolbar, click Add Study to close the Add Study window.

M E M B R A N E  A P P R O X I M A T I O N

1 In the Model Builder window, click Study 3.

2 In the Settings window for Study, type Membrane Approximation in the Label text field.

3 Locate the Study Settings section. Clear the Generate default plots check box.

Step 1: Stationary
1 In the Model Builder window, under Membrane Approximation click Step 1: Stationary.

2 In the Settings window for Stationary, locate the Physics and Variables Selection section.

3 Select the Modify model configuration for study step check box.

4 In the tree, select Component 1 (comp1)>Solid Mechanics (solid), Controls spatial frame>

Solid Approximation.

5 Click Disable.

6 Locate the Study Extensions section. Select the Auxiliary sweep check box.

7 Click Add.
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8 In the table, enter the following settings:

9 Click Range.

10 In the Range dialog box, type 0.1 in the Start text field.

11 In the Step text field, type 0.1.

12 In the Stop text field, type 0.5.

13 Click Add.

14 In the Settings window for Stationary, locate the Study Extensions section.

15 Click Add.

16 In the table, enter the following settings:

17 From the Sweep type list, choose All combinations.

18 From the Run continuation for list, choose Manual.

19 From the Continuation parameter list, choose stretch.

20 In the Home toolbar, click Compute.

R E S U L T S

Membrane Approximation
1 In the Model Builder window, expand the Results node.

2 Right-click Results and choose 2D Plot Group.

3 In the Settings window for 2D Plot Group, type Membrane Approximation in the Label 
text field.

4 Locate the Data section. From the Dataset list, choose Membrane Approximation/

Solution 3 (sol3).

5 Click to expand the Title section. From the Title type list, choose Manual.

6 In the Title text area, type Transition from Membrane Approximation to Perfect 
Interface.

7 Clear the Parameter indicator text field.

Parameter name Parameter value list Parameter unit

stretch (Stretch)

Parameter name Parameter value list Parameter unit

MuRatio (Scale factor for Lame 
parameter)

10^{range(-3,1,4)}
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8 Click to expand the Plot Array section. Select the Enable check box.

9 From the Array shape list, choose Square.

10 From the Padding list, choose Absolute.

11 In the Column padding length text field, type L.

12 In the Row padding length text field, type -2.4*L.

Surface 1
1 Right-click Membrane Approximation and choose Surface.

2 In the Settings window for Surface, locate the Data section.

3 From the Dataset list, choose Membrane Approximation/Solution 3 (sol3).

4 From the Parameter value (MuRatio) list, choose 10000.

5 Locate the Expression section. In the Expression text field, type solid.PxX.

6 From the Unit list, choose MPa.

Deformation 1
1 Right-click Surface 1 and choose Deformation.

2 In the Settings window for Deformation, locate the Scale section.

3 Select the Scale factor check box. In the associated text field, type 1.

4 In the Membrane Approximation toolbar, click Plot.

Surface 2
1 In the Model Builder window, under Results>Membrane Approximation right-click 

Surface 1 and choose Duplicate.

2 In the Settings window for Surface, locate the Data section.

3 From the Parameter value (MuRatio) list, choose 1000.

4 Click to expand the Inherit Style section. From the Plot list, choose Surface 1.

Surface 3
1 Right-click Surface 2 and choose Duplicate.

2 In the Settings window for Surface, locate the Data section.

3 From the Parameter value (MuRatio) list, choose 100.

Surface 4
1 Right-click Surface 3 and choose Duplicate.

2 In the Settings window for Surface, locate the Data section.

3 From the Parameter value (MuRatio) list, choose 1.
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Surface 5
1 Right-click Surface 4 and choose Duplicate.

2 In the Settings window for Surface, locate the Data section.

3 From the Parameter value (MuRatio) list, choose 0.1.

Surface 6
1 Right-click Surface 5 and choose Duplicate.

2 In the Settings window for Surface, locate the Data section.

3 From the Dataset list, choose Perfect Interface/Solution 1 (sol1).

Membrane Approximation
In the Model Builder window, click Membrane Approximation.

Table Annotation 1
1 In the Membrane Approximation toolbar, click More Plots and choose 

Table Annotation.

2 In the Settings window for Table Annotation, locate the Data section.

3 From the Source list, choose Local table.

4 In the table, enter the following settings:

5 Locate the Coloring and Style section. Clear the Show point check box.

6 Locate the Data section. Select the LaTeX markup check box.

7 In the Membrane Approximation toolbar, click Plot.

Line Plot: Membrane Approximation
1 In the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Line Plot: Membrane Approximation 
in the Label text field.

3 Locate the Data section. From the Dataset list, choose Membrane Approximation/

Solution 3 (sol3).

x-coordinate y-coordinate Annotation

0 3/2*L $\mu_{ratio}$ = 10000

2*L 3/2*L $\mu_{ratio}$ = 1000

4*L 3/2*L $\mu_{ratio}$ = 100

0 -3/2*L $\mu_{ratio}$ = 1

2*L -3/2*L $\mu_{ratio}$ = 0.1

4*L -3/2*L Perfect interface
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4 Locate the Axis section. Select the x-axis log scale check box.

5 Locate the Plot Settings section.

6 Select the x-axis label check box. In the associated text field, type \mu<sub>ratio</
sub>.

7 Select the y-axis label check box. In the associated text field, type First Piola 
Kirchhoff Stress (MPa).

8 Click to expand the Title section. From the Title type list, choose Label.

9 Locate the Legend section. From the Position list, choose Lower left.

Point Graph 1
1 Right-click Line Plot: Membrane Approximation and choose Point Graph.

2 Select Point 4 only.

3 In the Settings window for Point Graph, locate the y-Axis Data section.

4 In the Expression text field, type mean(side(1,solid.PxX)).

5 From the Unit list, choose MPa.

6 Locate the x-Axis Data section. From the Axis source data list, choose MuRatio.

7 Locate the Data section. From the Dataset list, choose Membrane Approximation/

Solution 3 (sol3).

8 From the Parameter selection (stretch) list, choose Last.

9 Click to expand the Legends section. Select the Show legends check box.

10 From the Legends list, choose Manual.

11 In the table, enter the following settings:

12 Click to expand the Coloring and Style section. Find the Line markers subsection. From 
the Marker list, choose Cycle.

13 In the Line Plot: Membrane Approximation toolbar, click Plot.

Line Segments 1
1 In the Model Builder window, right-click Line Plot: Membrane Approximation and choose 

Line Segments.

2 In the Settings window for Line Segments, locate the Data section.

3 From the Dataset list, choose Perfect Interface/Solution 1 (sol1).

Legends

Membrane Approx.
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4 From the Parameter selection (stretch) list, choose Last.

5 Locate the x-Coordinates section. In the table, enter the following settings:

6 Locate the y-Coordinates section. In the table, enter the following settings:

7 Click to expand the Legends section. Select the Show legends check box.

8 From the Legends list, choose Manual.

9 In the table, enter the following settings:

10 Click the Zoom Extents button in the Graphics toolbar.

Add a thin layer using a spring approximation to mimic a cohesive interface model.

S O L I D  M E C H A N I C S  ( S O L I D )

Spring Approximation
1 In the Physics toolbar, click Boundaries and choose Thin Layer.

2 Select Boundaries 7 and 8 only.

3 In the Settings window for Thin Layer, locate the Boundary Properties section.

4 In the Lth text field, type th.

5 Locate the Thin Layer section. From the Approximation list, choose Spring.

6 In the Label text field, type Spring Approximation.

Spring 1
1 In the Physics toolbar, click Attributes and choose Spring.

2 In the Settings window for Spring, locate the Spring section.

Expression Unit Description

0 1

1e-4 1

1e4 1

Expression Unit Description

aveop1(solid.PxX) MPa Average 1

aveop1(solid.PxX) MPa Average 1

aveop1(solid.PxX) MPa Average 1

Legends

Perfect Interface
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3 In the kA text field, type AlphaBnd.

4 In the ρV text field, type RhoBnd.

5 Select Boundaries 7 and 8 only.

A D D  S T U D Y

1 In the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select General Studies>Stationary.

4 Click Add Study in the window toolbar.

5 In the Home toolbar, click Add Study to close the Add Study window.

S P R I N G  A P P R O X I M A T I O N

1 In the Model Builder window, click Study 4.

2 In the Settings window for Study, type Spring Approximation in the Label text field.

3 Locate the Study Settings section. Clear the Generate default plots check box.

Step 1: Stationary
1 In the Model Builder window, under Spring Approximation click Step 1: Stationary.

2 In the Settings window for Stationary, locate the Physics and Variables Selection section.

3 Select the Modify model configuration for study step check box.

4 In the tree, select Component 1 (comp1)>Solid Mechanics (solid), Controls spatial frame>

Solid Approximation and Component 1 (comp1)>Solid Mechanics (solid),

Controls spatial frame>Membrane Approximation.

5 Click Disable.

6 Locate the Study Extensions section. Select the Auxiliary sweep check box.

7 Click Add.

8 In the table, enter the following settings:

9 Click Add.

Parameter name Parameter value list Parameter unit

stretch (Stretch) range(0.1,0.1,0.5)
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10 In the table, enter the following settings:

11 From the Sweep type list, choose All combinations.

12 From the Run continuation for list, choose Manual.

13 From the Continuation parameter list, choose stretch.

14 In the Home toolbar, click Compute.

R E S U L T S

Spring Approximation
1 In the Model Builder window, expand the Results node.

2 Right-click Results and choose 2D Plot Group.

3 In the Settings window for 2D Plot Group, type Spring Approximation in the Label text 
field.

4 Locate the Data section. From the Dataset list, choose Spring Approximation/

Solution 4 (sol4).

5 Click to expand the Title section. From the Title type list, choose Manual.

6 In the Title text area, type Transition from Spring Approximation to Perfect 
Interface.

7 Clear the Parameter indicator text field.

8 Click to expand the Plot Array section. Select the Enable check box.

9 From the Array shape list, choose Square.

10 From the Padding list, choose Absolute.

11 In the Column padding length text field, type L.

12 In the Row padding length text field, type -2.4*L.

Surface 1
1 Right-click Spring Approximation and choose Surface.

2 In the Settings window for Surface, locate the Data section.

3 From the Dataset list, choose Spring Approximation/Solution 4 (sol4).

4 From the Parameter value (AlphaRatio) list, choose 0.001.

5 Locate the Expression section. In the Expression text field, type solid.PxX.

Parameter name Parameter value list Parameter unit

AlphaRatio (Scale factor for 
stiffness)

10^{range(-5,1,3)}
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6 From the Unit list, choose MPa.

Deformation 1
1 Right-click Surface 1 and choose Deformation.

2 In the Settings window for Deformation, locate the Scale section.

3 Select the Scale factor check box. In the associated text field, type 1.

4 In the Spring Approximation toolbar, click Plot.

Surface 2
1 In the Model Builder window, under Results>Spring Approximation right-click Surface 1 

and choose Duplicate.

2 In the Settings window for Surface, locate the Data section.

3 From the Parameter value (AlphaRatio) list, choose 0.1.

4 Click to expand the Inherit Style section. From the Plot list, choose Surface 1.

Surface 3
1 Right-click Surface 2 and choose Duplicate.

2 In the Settings window for Surface, locate the Data section.

3 From the Parameter value (AlphaRatio) list, choose 1.

Surface 4
1 Right-click Surface 3 and choose Duplicate.

2 In the Settings window for Surface, locate the Data section.

3 From the Parameter value (AlphaRatio) list, choose 10.

Surface 5
1 Right-click Surface 4 and choose Duplicate.

2 In the Settings window for Surface, locate the Data section.

3 From the Parameter value (AlphaRatio) list, choose 1000.

Surface 6
1 Right-click Surface 5 and choose Duplicate.

2 In the Settings window for Surface, locate the Data section.

3 From the Dataset list, choose Perfect Interface/Solution 1 (sol1).

Spring Approximation
In the Model Builder window, click Spring Approximation.
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Table Annotation 1
1 In the Spring Approximation toolbar, click More Plots and choose Table Annotation.

2 In the Settings window for Table Annotation, locate the Data section.

3 From the Source list, choose Local table.

4 In the table, enter the following settings:

5 Locate the Coloring and Style section. Clear the Show point check box.

6 Locate the Data section. Select the LaTeX markup check box.

7 In the Spring Approximation toolbar, click Plot.

8 Click the Zoom Extents button in the Graphics toolbar.

Line Plot: Spring Approximation
1 In the Model Builder window, right-click Line Plot: Membrane Approximation and choose 

Duplicate.

2 In the Settings window for 1D Plot Group, locate the Data section.

3 From the Dataset list, choose Spring Approximation/Solution 4 (sol4).

4 Locate the Plot Settings section. In the x-axis label text field, type \alpha<sub>ratio</
sub>.

5 In the Label text field, type Line Plot: Spring Approximation.

6 Click to expand the Title section. From the Title type list, choose Label.

7 Locate the Legend section. From the Position list, choose Lower right.

Point Graph 1
1 In the Model Builder window, expand the Line Plot: Spring Approximation node, then 

click Point Graph 1.

2 In the Settings window for Point Graph, locate the Data section.

3 From the Dataset list, choose Spring Approximation/Solution 4 (sol4).

x-coordinate y-coordinate Annotation

0 3/2*L $\alpha_{ratio}$ = 0.001

2*L 3/2*L $\alpha_{ratio}$ = 0.1

4*L 3/2*L $\alpha_{ratio}$ = 1

0 -3/2*L $\alpha_{ratio}$ = 10

2*L -3/2*L $\alpha_{ratio}$ = 1000

4*L -3/2*L Perfect interface
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4 Locate the Legends section. In the table, enter the following settings:

5 In the Line Plot: Spring Approximation toolbar, click Plot.

Line Segments 1
1 In the Model Builder window, click Line Segments 1.

2 In the Settings window for Line Segments, locate the x-Coordinates section.

3 In the table, enter the following settings:

4 In the Line Plot: Spring Approximation toolbar, click Plot.

Disable some features in the studies to be able to rerun them.

P E R F E C T  I N T E R F A C E

Step 1: Stationary
1 In the Model Builder window, expand the Perfect Interface node, then click 

Step 1: Stationary.

2 In the Settings window for Stationary, locate the Physics and Variables Selection section.

3 Select the Modify model configuration for study step check box.

4 In the tree, select Component 1 (comp1)>Solid Mechanics (solid), Controls spatial frame>

Solid Approximation, Component 1 (comp1)>Solid Mechanics (solid),

Controls spatial frame>Membrane Approximation, and Component 1 (comp1)>

Solid Mechanics (solid), Controls spatial frame>Spring Approximation.

5 Click Disable.

S O L I D  A P P R O X I M A T I O N

Step 1: Stationary
1 In the Model Builder window, expand the Solid Approximation node, then click 

Step 1: Stationary.

2 In the Settings window for Stationary, locate the Physics and Variables Selection section.

Legends

Spring Approx.

Expression Unit Description

0 1

1e-5 1

1e3 1
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3 Select the Modify model configuration for study step check box.

4 In the tree, select Component 1 (comp1)>Solid Mechanics (solid), Controls spatial frame>

Membrane Approximation and Component 1 (comp1)>Solid Mechanics (solid),

Controls spatial frame>Spring Approximation.

5 Click Disable.

M E M B R A N E  A P P R O X I M A T I O N

Step 1: Stationary
1 In the Model Builder window, expand the Membrane Approximation node, then click 

Step 1: Stationary.

2 In the Settings window for Stationary, locate the Physics and Variables Selection section.

3 In the tree, select Component 1 (comp1)>Solid Mechanics (solid), Controls spatial frame>

Spring Approximation.

4 Click Disable.
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